Friday, June 17, 2016

And More: Color Differences When Opening or Importing Images with PaintShop Pro X8 [Fix/Workaround]



I am just finishing up a Trial for Corel's PaintShop Pro X8, an image editing program which I enjoyed testing out - and while it had very few issues or problems [for me personally], I did run into one where, upon importing (opening or pasting) an image, the colours seemed altered/changed (looking like they had been 'reduced' perhaps) as can be seen by this brief comparison I put together for uploading to a forum:

In the example comparison above, the difference can be seen mainly in the lower-left portion, the darker area - which seems 'blotchy' and the image appears to have less colour, but the palette [the amount of colours the image holds] shows RGB/16bit


I mentioned this on the Corel User Forum to see if anyone had any ideas... Perhaps it was a setting somewhere in X8 I missed [I thought to myself]. I Disabled the 'Automatically Convert Colour to 8bit' (changing it to Prompt instead of Automatically convert) but that did not seem to have an effect [it is usually only used for certain needs anyway, such as Animated GIF images, as it reduces the palette down to 256 colors, but I thought it was worth a shot in case it 'triggered' something else in the program].

I did not run into this issue/problem with PaintShop Pro X7, a great image editing application that I continue to enjoy to this day - in fact, all the images on this Blog and other places I share them - I do a Final create/compile with either PaintShop Pro or GIMP (which is a versatile Open Source Image Editing Program with an interface similar to Photoshop). 

[Note: I am not affiliated with nor do I receive any compensation in any form from Corel for talking about or using PaintShop Pro - I am merely an enthusiast user of the program for image editing purposes and wish to share my own discovered information with other like users of the program]


The Corel User To User Web Board (Corel's Support Forum, they can still be contacted directly for problems) was once again very helpful with information on what was going on here...

Apparently, there is an issue with Color Management that many people seem to be having, with PaintShopPro version 18 (X8), which does not occur in X7 (which turned out to be the exact issue I myself was running into!).


The solution/fix was to Disable the Color Management in X8, by going to

File > Color Management > Color Management

and Uncheck the checkbox in that window to Disable the management system in PaintShop Pro.

Example of what the Color Management window looks like and the simple solution
to the color issue/problem in Paintshop Pro X8 (Click to see Full Size)


Although I do not know the details of why the problem itself is occurring in X8 (and the exact details were not given at the Forum at the time), the fix/workaround did in fact work for me and I no longer experienced this issue of color reduction/loss in X8 - and I wanted come here to share it with everyone in the hopes that it works for others experiencing this problem, too!

If I had to summarize Color Management, I would state it is a way of matching up colours from different sources, such as making sure that an image taken with a camera will be reproduced correctly on a printer, etc. While the average home user does not really have a need for this, professional photographers, publishers and printing houses appreciate these options (which has a list of various devices, like printers, monitors and so on, so that 'what they see is what they get', which is something they really want).


[The original Thread where I asked about this issue at the Corel User Forum (with the helpful answer by Kathy_9, an advisor at the site), can be found at: http://forum.corel.com/EN/viewtopic.php?f=56&t=59642&p=328249  ]

Hopefully this fixes the problem for you too, dear reader, if you run into it - enjoy!