Wednesday, May 17, 2017

And More: Corel's VideoStudio - Crashing When Using 'Open With' To Import Clips Into VideoStudio [Fix/Workaround]


Just last Month, I picked up version 20 of Corel's recently-updated video editing suite "VideoStudio" (nomenclature "X10") and am having a lot of fun learning what it can do and how to do it all (coming from mainly editing videos with Sony's Vegas 'Movie Studio' line of products [now taken over by MAGIX]). However, I quickly ran into a little issue with importing clips using the "Open With" option in Windows and wanted to share what I found...




Normally, in Windows you can 'right-click' a video file and mouse-over the menu option "Open With..", which brings up a sub-menu of known applications, to 'send' the file to ('opening the file with the chosen application'). Doing this, whichever application you select will startup and the file will be sent to it to work with.


However, doing this with a video clip and VideoStudio x10 I found, every time the program would open up, it would immediately 'crash' (close/stop/etc). Hmm... time for some Troubleshooting! I double-checked that the file in question was not corrupted excessively by playing it, testing it in a couple of video/media players, and even tried a few other clips that were 'known good' (that VS worked with before). Each time, using "Open With...", the Splash Screen for VSx10 would show up and then just as the program itself looked like it was opening, the entire thing would crash and show this message:

Example of the "Corel VideoStudio has stopped working" Error Window Pop-Up
when trying to import a clip into VideoStudio X10 utilizing the "Open With" shortcut in Windows


I then went to the Corel 'Official' Fora [Forii?] and did some searching to see if anyone ran into this same issue. Unfortunately, all I could find were people experiencing 'general crashes', that is, crashing and non-starts without it being specifically associated with utilizing "Open With..".

I then decided to try these same 'testing files' on some other video editing programs I have installed, such as Sony's Vegas Movie Studio (now owned by MAGIX, the same company that makes the Movie Edit Pro product line, which I have no experience with yet, at this time). Using the "Open With.." command, Movie Studio was able to open and import all of the video clips without issue - so then, what's up Corel? /tilthead

I thought of trying VideoStudio 'on it's own', not importing or 'sending' anything to it - just opening the program and seeing if it works... Everything opened fine! I was just playing with the program the other day in fact, learning some of the features it offers [I'll have to write a short 'Review' or at least a 'First Impressions' sometime of it]. So why was it being 'fussy' (to use the highly technical term)? I tried opening and closing the program a few times thinking about it, when I noticed that when I opened VideoStudio X10, I was being greeted by a nice-and-helpful "Welcome" StartUp Page...

The "Welcome" Section of VideoStudio
(Click to see Full Size)

Indeed, 'The "Welcome" Startup Page' offers a lot of helpful information on opening VideoStudio. There are Tutorial videos on some of the New Features for that version and even Basic Tutorials and Help File links. But wait - no editing interface! No Timeline, no Media Library to add clips - that's it! That's the problem! I went into the Settings to see if there was a Preferences option where I could set the Section to open VideoStudio to be - not the "Welcome" section, but the "Edit" section - the tab/area where all of the editing/mixing and importing takes place. There it was: Default Startup Page - and it was set to "Welcome Book"...

The Corel VideoStudio X10 Preferences Window
showing the Default Startup Area/Section which is shown when the program starts
(Click to see Full Size)

A simple pull-down menu change to "Edit" and that was it! Now, VideoStudio is opening to the "Edit" section/area every time. So, I tested it out: right-clicking on my video clip and mousing-over "Open With.." and then clicking on "Corel VideoStudio" - it worked! VS opened up and in a few seconds more, my little video clip was right there on the Timeline, waiting patiently to be edited. Woohoo!

Example of Corel VideoStudio x10 Starting Up In The EDIT Section
(Click to see Full Size)


Here is a video version of the steps above, made showing the error when trying to use "Open With..", what happens and how to change it, as well as the final 'working' result of changing the option (after I finally figured out what it was):


[VIDEO NOT YET COMPLETE, IT WILL APPEAR HERE ONCE FINALIZED AND UPLOADED TO YOUTUBE]


Hopefully this will help any of you dear readers, who use VideoStudio and were running into this error/crash/issue when opening clips with VS (trying to use "Open With..").. Enjoy and Have Fun editing your gameplay clips once again!

~Troy from The Game Tips And More Blog



[I'm calling this a Workaround, since this is more of that than a true 'Fix'... It does not solve the base issue of VS not being able to import a clip using "Open With" without taking taking these steps (whether this is more Microsoft's fault or Corel's fault is beyond the scope of this post ...and being more experienced in computer hardware than computer software (programming, etc), I would not have completely isolated the very base cause of the issue anyway - or at least, could not offer a 100% explanation of what is occurring)]


Note: I am not affiliated in any way with Corel and I have not, and I will not, be compensated for mentioning VideoStudio or any other of the products herein, in any way.  I have used other video editing products than these in the past, and will do so in the future, including free editing applications, such as VirtualDub, AviDemux, DVDVideoSoft products and more... I am merely an enthusiastic gamer-and-sometime-editor and wanted to share information that I discover about these products to help other gamers record-and-edit and have fun doing it, if I can do so.

No comments:

Post a Comment